#!++ install on late 2006 iMac 5,2

I have just retired an old iMac from our browser testing lab due to age, the model is an iMac 5,2 with 2GB memory and Core 2 Duo 1.83 Ghz processor. It runs 10.6.8 (Snow Leopard) quite well, but 10.7.4 (Lion) runs like a…